Actions

ComfortUpdate

From LimeSurvey Manual

This page is a translated version of the page ComfortUpdate and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎Nederlands • ‎Tiếng Việt • ‎dansk • ‎español • ‎français • ‎italiano • ‎magyar • ‎polski • ‎português do Brasil • ‎română • ‎slovenščina • ‎български • ‎русский • ‎日本語

General

ComfortUpdate este un serviciu profesional de la LimeSurvey GmbH pentru a actualiza LimeSurvey cu ușurință din browser-ul dvs. web, cu doar câteva clicuri de mouse (în loc să fie nevoie să efectuați o actualizare manuală).

Pentru a utiliza și a testa ComfortUpdate, trebuie să vă înregistrați pe LimeSurvey pentru a primi o cheie de încercare gratuită. După ce acea cheie de încercare a expirat, puteți fie să cumpărați unul dintre pachetele noastre premium, fie să să vă actualizați manual instalarea.


Template:Alertă

Cerințe

Instalarea dvs. PHP trebuie să fie compilată cu suport pentru ZLib și să aibă Extensia .php OpenSSL instalată și activată. Verificați-vă PHPInfo sau cereți o confirmare administratorului de sistem.

Serverul dvs. trebuie să se poată conecta prin SSL la „comfortupdate.limesurvey.org” pentru a utiliza instrumentul ComfortUpdate. Dacă întâmpinați probleme și primiți mesaje de eroare precum „10060 nu s-a putut conecta la gazda „comfortupdate.limesurvey.org””, va trebui să modificați/editați setările de securitate proxy/firewall sau să cereți îndrumări suplimentare administratorului serverului. /Ajutor.

Utilizarea ComfortUpdate

Caracteristica LimeSurvey ComfortUpdate este sigură de utilizat chiar și cu sondaje active. Nu șterge sau distruge datele existente. Cu toate acestea, din precauție, ar trebui să faceți backup manual pentru baza de date și fișierele curente înainte de a continua.

  • Găsiți butonul „Actualizare”
    • Pentru versiunile mai vechi de LimeSurvey, accesați pictograma Setări globale, selectați prima filă și faceți clic pe butonul „Actualizări”
    • Pentru Limesurvey recent versiuni, veți găsi butonul ComfortUpdate în dialogul Configurare, sub fila Avansat:


ComfortUpdate.png


  • Ecranul ComfortUpdate va afișa un link de actualizare dacă este disponibilă o nouă versiune de LimeSurvey. Dacă nu, faceți clic pe „Verificați acum” pentru a vedea dacă este disponibilă o nouă actualizare
  • Dacă este găsită o actualizare, LimeSurvey va afișa un link pentru a vă permite să actualizați. Faceți clic pe aceasta pentru a începe actualizarea
  • Dacă nu ați mai folosit niciodată ComfortUpdate sau cheia de upgrade ComfortUpdate nu este validă, vi se va cere să introduceți o cheie de actualizare.


ComfortUpdateKey.png


  • LimeSurvey va verifica acum directorul de instalare pentru a verifica dacă permisiunile corespunzătoare sunt setate pentru a permite o actualizare. Va fi afișată o listă de modificări propuse
  • Dacă există probleme, trebuie să le corectați în acest moment și apoi să treceți la pasul următor
  • ComfortUpdate va face acum o copie de rezervă a bazei de date (dacă utilizați MySQL) și salvați fișierele de instalare vechi în directorul /tmp. Dacă utilizați o altă bază de date, ar trebui să faceți backup manual pentru baza de date înainte de a continua

ComfortUpdate va actualiza acum instalarea la cea mai recentă versiune, actualizând și baza de date pentru a reflecta noile (posibile) modificări.

Dezactivarea ComfortUpdate

Pentru a dezactiva ComfortUpdate pentru a evita primirea mesajelor pop-up „New release available” după fiecare nouă lansare, puteți adăuga următoarea opțiune la fișierul „config.php” (care se află în /limesurvey/application/config):

 
'updatable' => fals

Cu toate acestea, vă recomandăm insistent să nu dezactivați această opțiune, deoarece este posibil să pierdeți actualizări importante de securitate.

Depanare

Primesc o eroare în timpul ComfortUpdate

Ca prim pas, vă rugăm să încercați să rulați din nou același pas după un minut. Ocazional, serverul trebuie să genereze mai întâi pachetul de actualizare, ceea ce poate dura un minut. Dacă tot nu funcționează, verificați celelalte soluții din această secțiune de depanare.

Niciun răspuns server - Serverul ComfortUpdate nu răspunde

Începând din decembrie 2022, conexiunea implicită la serverul nostru actualizat a fost schimbată pentru a utiliza numai SSL. Acest lucru necesită ca biblioteca OpenSSL PHP de pe serverul dvs. să fie configurată corect și activat și că serverul dumneavoastră are permisiunea de a se conecta prin conexiune HTTP SSL în exterior (la serverul nostru comfortupdate.limesurvey.org). Dacă una dintre aceste cerințe nu este îndeplinită, veți primi acest mesaj. A Soluția „temporană” (pe care nu o recomandăm) este să dezactivați această cerință în /application/config/updater_version.php prin setarea

 
$config['comfort_update_server_ssl'] = 0;

Pagină goală la pasul 3

Dacă primiți o pagină goală la pasul 3, înseamnă de obicei că limita de memorie a configurației dvs. PHP este setată prea mică. În timpul acestui pas, LimeSurvey încearcă să creeze o copie de rezervă a bazei de date și o copie de rezervă a fișierelor (a fișierelor care vor fi înlocuite).

Utilizarea unui server proxy pentru a vă conecta la update.limesurvey.com

Dacă vă aflați în spatele unui proxy, poate fi necesar să ajustați unele setări pentru a putea folosi ComfortUpdate. Puteți seta detaliile serverului dumneavoastră proxy în fișierul de configurare (consultați wiki-ul setărilor generale).