Actions

回答結果の出力

From LimeSurvey Manual

This page is a translated version of the page Exporting results and the translation is 100% complete.

Other languages:
Deutsch • ‎English • ‎français • ‎日本語 • ‎Nederlands • ‎português do Brasil • ‎slovenščina
Important.png
注意 : 以下のセクションの内容は古くなっています。最新の情報はこちらを参照してください。


Contents


アンケートを公開すると、回答の閲覧や出力ができるようになります。アンケート回答の概要を確認するには、

Browse results.png

アプリケーション用に出力(Excel/.csv)

ページ上部に出力のオプションがいくつかあります。

Export2.png

結果を出力する際、いくつかの条件でフィルタリングすることができます。

  • 全般
    • レコードXからYのように出力する範囲を指定する
    • すべての回答、または完了した回答、未完了の回答に限定して出力する
  • 質問
    • ヘッダーの付け方: 簡略化された質問、質問テキスト全文、質問コード
    • 質問テキストのスペースを下線に変換
  • 回答
    • 全回答、または回答コードY/Nを決められた変数に変換したものを出力できます
  • 出力形式
    • Microsoft Word(ラテン文字セット)
    • Microsoft Excel(すべての文字セット)
    • CSVファイル(すべての文字セット)
    • HTML
    • PDF
    • 出力する回答をセットします。リストの回答はすべてSGQA識別子で表されます。
    • どのトークンデータを出力するか設定します。このオプションは、アンケートが 匿名でない時だけ利用できます。

Export tokens.png

SPSS出力

概要

SPSS Statisticsは、バッチ型、非バッチ型の統計分析に使用されるソフトウェアパッケージです。公式のSPSSパッケージのほか、SPSSの代替であるGNU PSPPも使用できます。

回答データをSPSSに出力するには、「回答と統計」にアクセスし、SPSSに出力するアイコンをクリックします。

出力およびデータのフィルタリング

データをSPSSに出力する場合、2つのフィルターオプションがあります。どのデータを出力するか(すべて/完了/未完了)、出力するファイルはどのバージョンのSPSSで使われるか(バージョン16より前、16以降)を指定します。

SPSS出力では、2つのファイルが出力されます。

  1. シンタックスファイル(survey_xxxx_SPSS_syntax_file.sps
  2. データファイル(survey_xxxx_SPSS_data_file.dat

ファイルを出力したら、メモ帳のようなテキストエディターで出力データを開き、どのようなものか見ることができます。シンタックスファイルには、データをインポートするときに実行されるコマンドが記載されています。これは、SPSS内部のプログラム言語のようなものです。データファイルは、すべてのデータがカンマで区切られています。ウィザードからただのCSVファイルとしてインポートすると、質問やラベルセットなどの情報が失われてしまうため、この方法は使用しません。

SPSSでのデータインポート

2つのファイルをドライブの同じフォルダに配置します。(例: c:\data\survey_xxxx_SPSS_syntax_file.spsc:\data\survey_xxxx_SPSS_data_file.dat

2つの選択肢があります。

1. Windowsを使用している場合は、エクスプローラーを使用して上記のフォルダを参照します。SPSSが.spsファイル拡張子に関連付けされている場合は、ファイルをダブルクリックするだけで開くことができます。

Spss explorer-screenshot.jpg

開いたウィンドウから「実行」->「すべて」を選択し、しばらくしてから通常の.savファイルとして保存できる出力データセットが得られます。

2. 上記の簡単な方法がうまくいかない場合は、次のようにします。

  • SPSSを開く
  • 「ファイル」->「開く」->「シンタックス」を選ぶ
  • 該当するファイルを選択する)(c:\data\survey_xxxx_SPSS_syntax_file.sps)
  • シンタックスが開きます。
  • /FILE='survey_xxxx_SPSS_data_file.dat' という行を変更して、ファイルのパスを追加します。 /FILE='c:\data\survey_xxxx_SPSS_data_file.dat' 。Macユーザーの場合は、/FILE='HD/Users/username/survey_xxxx_SPSS_data_file.dat' となります。
  • 次に、コマンドテキスト全体をマークし、メニューから「実行」->「すべて」を選択してください。しばらくしてから、質問、ラベルなどのすべての情報を持つデータセットが得られます。

Rエクスポート

情報をお持ちの場合は、追加してください!

フリーウェアソフトウェアRはSPSSの代替品です。Limesurveyのアプリケーションエクスポートで出力します。

Rでデータセットをインポートする方法です。

  1. シンタックスファイルとデータファイルの両方をダウンロードします。
  2. 両方のファイルをRの作業ディレクトリーに保存します(取得および設定するには、Rコマンドウィンドウでgetwd()setwd()を使用します)。
  3. Rのコマンドウィンドウで、source("Surveydata_syntax.R", encoding = "UTF-8")と入力し、"data"と呼ばれるデータフレームに正しい書式でデータをインポートします。


選択肢が限定された質問の回答は、質問のコードと一致するラベルと選択肢と一致するラベルに分解されます。

「その他」のオプションが追加された質問では、「その他」データ用の新しい列として「_Other」という質問フィールドが追加されます。

注意: R-exportはLimesurveyのプラグインです。結果をアプリケーションに出力でR-exportオプション(R (syntax file)R (data file))が見つからないときは、プラグインメニューでR-exportプラグインが有効になっているか確認してください。

STATA-xmlエクスポート

この機能はバージョン2.05から利用可能です。

STATAは、商用のデータ分析・統計ソフトウェアパッケージです。

このエクスポートルーチンは、LimeSurveyで収集されたデータの迅速な分析を容易にするために作成されました。STATA独自のフォーマットでXMLファイルが作成され、STATAが実行されているプラ​​ットフォームとは独立してインポートできます。この形式を使用すると、プレーンなCSVファイルをインポートする場合に比べていくつかの利点があります。

  • データセットは、変数ラベル(質問、サブ質問)と値ラベル(回答)を含め、完全にラベル付けされています。
  • 日付はすでにSTATAの内部日付形式に変換されているため、日数計算などで直接使用できます。
  • 変数名は、必要に応じてSTATA互換フォーマットに変換されます。
  • 変数(文字列、整数、浮動小数点数など)のデータ形式は、データに基づいて設定されています(もう数字が文字列としてエンコードされることはありません)。

STATAでファイルをロードする方法: STATAのメニューで、「ファイル」、「インポート」、「xmlデータ」をクリックします。エクスポートしたファイルを選択して'OK'をクリックします。 STATAのバイナリーファイル形式である.dtaファイルがほしい場合は、データをこの形式で再度保存するだけです。

注意:

  • STATAのデータフォーマットの制限により、文字列(テキスト)変数の長さは、Stataバージョン8-12では最大244文字、Stataバージョン13以上では2045文字です。エクスポートプラグインの設定でStataのバージョンを指定してください。
  • STATAは数値に値ラベルを付けることしかサポートしていません。短い回答(1‐2文字)で正しくラベル付けするには、LimeSurveyで数字の回答コードを使用する必要があります(1=「完全に同意する」など)。数字以外の回答コードを使用するとき(A=「完全に同意する」など)は、回答としてテキストが使用されます(例:「完全に同意する」)。

VVExport (File:Exportvv.png)とVVImport (File:Importvv.png)

Notice.png
Hint: この機能はバージョン2.05から変更されました。


回答の収集を開始したら、(表計算ツールを使うべきレベルの)大量の回答データを直接編集して変更しなければならない場合があるかもしれません。

VVExport("VV"は垂直検証を意味します)では、回答テーブルを.csvファイルにエクスポートできます。ファイルの全般的な構造がそのまま残っている限り、ファイルの中の値を編集してから、"VVImport"機能を使用してファイルを再度回答テーブルにインポートすることができます。

注意点:

  • "VVImport"を使用して回答をインポートする場合は、既存の回答に回答を追加するのか、すべての回答を上書きするのかを確認してください。
  • 質問は同じだが別のアンケートから回答をインポートしようとしている場合は、vvファイルが正しいもので、.csvファイルの最初の2行が正しいことを確認してください。
  • アンケートをLimeSurveyにインポートすると、SIDは(可能な場合)変更されません。ただし、グループIDと質問IDは変更される可能性があります。したがって、最初の2つの見出し行を新しいグループID/質問IDと一致するように調整する必要があります。vvファイル見出しの調整を参照してください。

VVExportファイルバージョン2 (2.05 から追加)

この新しい機能では、データベースとは異なる列名が使用できます。質問コードがユニークである場合、新しいバージョンが選択されます。新しいバージョンでは、各列名はQcode変数命名法を使用します。これにより、たとえば、異なる環境の既存のアンケートをより簡単に更新することができます。

VVアンケートファイルのエクスポート

File:LimesurveyExportVVen.jpg

VVExportを使用して回答をエクスポートしようとすると、すべての回答をエクスポートするか、または完了した回答のみか、未完了な回答のみかを選択するオプションが表示されます。ファイル拡張子を使用すると、エクスポートされるファイルの拡張子を選択できます。通常は.csvを選択します。

'vv survey file'では、質問/回答の組み合わせが変更されたときに回答をアンケートにインポートできます。これにより、アクティブなアンケートで効果的に質問を追加・削除することができます。

"VVアンケートファイルを出力"をクリックすると、Excelまたは同様のスタイルの表計算プログラムで開くことができるタブ区切りファイルが作成されます。スプレッドシートの最初の2行は列ラベルです。最初の行は、質問・回答フィールドの名前を詳述する"人間が判読可能な"列見出しです。2番目の行は、その回答の内部PHP/データベース列名です。

データを後でLimeSurveyに"インポート"できるようにしたい場合は、このスプレッドシートの最初の2行を変更しないでください。

VVアンケートファイルのエクスポート (2.05 から追加)

Notice.png
Hint: この機能は、バージョン2.05以降で使用できます。


VV2-export-en.png
  • 出力アンケート : 出力されるアンケートID(読み取り専用)
  • 出力 : エクスポートされる回答の完了・未完了の状態
  • ファイル拡張子 : ファイル拡張子。ファイルはTSV(Tab-separated values)ファイルです。MS-Excelで簡単に開くには、拡張子を.txtに設定し、LibreOffice、OpenOffice、または他のスプレッドシートプログラムでは.csvのままで大丈夫です。
  • VV出力バージョン : バージョン1.0はデータベース列ヘッダを使用し、バージョン2.0はQcode変数名を使用します。すべての質問コードが一意の場合は、デフォルトでバージョン2.0が選択されます。

スプレッドシートの最初の2行は列ラベルです。最初の行は、質問の名前を詳述する"人間が判読可能な"列見出しです。2番目の行は、その回答の実際の列名(内部DBまたはQcode名)です。

VVアンケートファイルの編集

.vvファイルが正常にエクスポートされたら、スプレッドシートツールを使用してファイルを開いて編集できます。ファイルを開くときに列区切りを選択する必要がある場合は、"タブ"文字を使用してください。非ASCII文字を使用している場合は、文字セットとして "UTF-8"を設定してください。

Important.png
エクスポートされたvvファイルの編集にMicrosoft Excelを使用している場合、Excelがファイルの元のデータ構造を破壊してしまいます。これにより、編集した.vvファイルを再インポートしようとするとエラーが発生します。

既定では、.vvファイルの最初の2行はヘッダーです。必要に応じて、最初の行を削除して実際のTSVファイルを作成することができます。.vvファイルをインポートする用途はいろいろあるので、アンケートに新しい回答を追加することと、アンケートのすべての回答を上書きすることが区別されます。

.vvファイルの構成の例:

VVバージョン1 TSVファイル

Response ID	Date submitted	Last page	Start language	Token	1~6を選択してください (1 - 素晴らしい、6 - ひどい)
id	submitdate	lastpage	startlanguage	token	46492X40X1991
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1

VVバージョン2 TSVファイル

Response ID	Date submitted	Last page	Start language	Token	1~6を選択してください (1 - 素晴らしい、6 - ひどい)
id	submitdate	lastpage	startlanguage	token	QCODE
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1


ここでは、SQGA識別子は使用されません。代わりに2行目でQcode変数名のQCODEが使用されます。

予約名

.VVファイルは、次の文字列をインポートするとき、予約名の左右に括弧をつけます。

  • {question_not_shown} : データベースのNULL値。LimeSurveyは、回答されていない質問に対しては[空文字列]を使用し、(式マネージャーまたはアンケートの最大ステップによって)表示されない質問に対してはNULL値を使用します。
  • {quote} : "(二重引用符)
  • {cr} : キャリッジリターン
  • {newline} : 新しい行
  • {lbrace} : 左括弧(例えば回答に{cr}を使用したい場合は{lbrace}cr}を使います)

VVバージョン1の編集

既存の回答に新しい回答を追加する

フォーマットのバージョン1では、間違った列にデータをインポートするなどさまざまな問題が発生しやすいため、サポートされていません。.vvファイルのバージョン1は、Excelなどの外部ツールでデータを垂直検証するためのもので、別の情報源(別のサーバー上で実行されている同じアンケートなど)からデータを集めるためのものではありません。

アンケートの全回答の編集

アンケートの回答を変更したい場合は、ファイルを編集するだけです。

例:

手順1: ファイルを開く

Response ID	Date submitted	Last page	Start language	1~6を選択してください (1 - 素晴らしい、6 - ひどい)
id	submitdate	lastpage	startlanguage		46492X40X1991
183	09.11.11 11:44	3	de	4
184	09.11.11 11:53	3	de	2
190	09.11.11 11:44	3	de	1


手順2: 回答を修正する

Response ID	Date submitted	Last page	Start language	1~6を選択してください (1 - 素晴らしい、6 - ひどい)
id	submitdate	lastpage	startlanguage		46492X40X1991
1000	09.11.11 11:44	3	de	3
1001	09.11.11 11:53	3	de	3
1002	09.11.11 11:44	3	de	3

アンケートをインポートして、既存の回答を上書きすることができます("VVアンケートファイルのインポート"を参照)。

VVアンケートファイルのインポート

File:LimeSurveyImportVVen.jpg

最初の2行がそのままであれば、vvアンケートファイルのデータを稼働中のLimeSurveyアンケートにインポートすることができます。

Microsoft Excelを使用してエクスポートしたvvファイルを編集した場合、このファイルのデータ構造が壊れている可能性があるため、LimeSurveyは編集したファイルをインポートできません。インポートをエラーなく実行するには、次の回避策を試してみてください。

  • エクスポートされたvvファイルをExcelで開き、変更を加えてください(すでに行っているでしょう)。
  • タブ区切りのテキストファイルとして保存します(拡張子.txtの新しいファイルを作成します)
  • LimeSurveyから別の"クリーンな"vvエクスポートを実行する
  • 新しくエクスポートされたvvファイルをメモ帳などのテキストエディタで開く(Macならtextwranglerなど)
  • Ctrl + Aキーを押してすべてのコンテンツを選択し削除します
  • Excelで編集したvvファイル(タブで区切られた.txtファイル)をテキストエディタで開き、CTRL + Aを押してすべてのコンテンツを選択します。
  • Ctrl + Cキーを押して内容をコピーし、新しい(現在空の)vvファイルに貼り付けます。
  • ファイルをそのまま(.csvとして)保存するには、Ctrl + Sキーを押します。
  • このファイルをインポートします。

次に、ブラウズ画面から、"VVアンケートファイルのインポート"アイコンを選択します。

"VVアンケートファイルをインポート"画面では、インポートする"vvexport"ファイルを選択します。"レコードIDを除外する"を選択した場合、レコードをインポートするときに、新しいレコードIDが生成されます(ユースケース"既存のアンケートの回答に新しい回答を追加する"の場合はこのオプションを使用します)。このボックスのチェックを外すと、元のレコードIDがインポートされます(ユースケース"アンケートのすべての回答を上書きする"の場合はこのオプションを使用します)。

LimeSurveyで、重複するエントリを処理する方法を選択できるオプションがあります。

  • エラーを報告する(新しいレコードをスキップする)
  • 新しいレコードの番号を変更する
  • 既存のレコードを置き換える(ユースケース"アンケートのすべての回答を上書きする"に使用)

VVアンケートファイルのインポート (2.05 から追加)

  • ファイル : アップロードするファイルを選択します。ファイルはTSVファイル(各列がタブ文字で区切られたテキストファイル)でなければなりません。
  • レコードIDを除外しますか? : ファイルに 'id'列がある場合、この行を除外するかどうかを指定できます。この設定をチェックすると、.vvファイルの各行に新しいレコードが追加されます。チェックを外すと、次のいずれかを選択できます。
  • インポートしたレコードが、既存のレコードIDと一致する場合:
    • エラーを報告(新しいレコードにスキップ) : 新しいレコードを報告してスキップします。アップロード後に、レコードがすでに存在していたかについてレポートが表示されます。レコードが存在ていた場合は、インポートされません。
    • 新しいレコードの番号を付け直す : 新しいレコードの番号を付け直します。新しいレコードがVVファイルの既存の回答とともに回答テーブルに追加されます。
    • 既存のレコードを置き換える : 既存のレコードを置き換えます。古いレコードは削除され、VVファイルのレコードに完全に置き換えられます。
    • 既存レコードの回答部分のみ置き換えます : 既存のレコードの回答を、ファイルにある情報に置き換えます。古いレコードは、VVファイルからの新しい回答で更新されます。これにより、回答テーブル内の1つの質問のみを置き換えることができます。
  • 未完了回答としてインポート? : チェックされている場合、submitdateはNULLに設定されるため、回答は未完了扱いとなります。
  • ファイルの文字セット : ファイルの文字セットを選択できます。既定値と推奨値はUTF-8ですが、一部の表計算プログラムでは文字セットを選択できません。
  • 質問コードが1行目にある : 既定では、VVファイルの最初の行には人が読める質問が含まれています。実際の列名は2行目にあります。この設定により、最初の行を実際の列名として使用できます。
  • 強制インポート : データベース名またはQcode変数名に質問コードが見つからない場合は、順番に従って列が割り当てられます。これは、別の環境のLimeSurveyからVVファイルをインポートするために使用できますが、各々のアンケートは完全に同一でなければなりません。あなたが何をしているのか分かっている場合にのみ、これを使用することを強くお勧めします。非常に危険で、結果として間違った列になることがあります。

その他の出力オプション

単一の回答を出力する

個別の回答をエクスポートする場合は、3つの方法で対応できます。

1. Limesurveyの管理用バックエンドにログインし、アンケートを選択し、"アンケート設定の編集"→"通知とデータ管理"に進み、基本的な電子メール通知を受け取るようにします。

誰かがアンケートを完了するたびに、"個々の回答を見るには次のリンクをクリックして下さい"というリンクが付いたメールが届きます。

このリンクをたどると、データの上に"この回答を出力"というボタンが表示されたページに移動します。

2. Limesurveyの管理用バックエンドにログインして、アンケートを選択し、このアンケートの回答を表示します。エクスポートするID番号の行の左側の列にある"回答詳細を表示"をクリックします。次に、データの上にある"エクスポート"をクリックします。

3. Limesurveyの管理用バックエンドにログインし、アンケートを選択し"結果をアプリケーションにエクスポート"します。"データのエクスポート"の最後のフィールドで、エクスポートするエントリを選択できます。

別のアンケートの回答を突き合わせる

LimeSurveyでは、特定の個人が時間の経過とともにアンケートにどう回答したか追跡することができます。例えば、あるセミナーの受講前後でグループの回答を追跡する場合に使えます。

これを実装する手順は次のとおりです。

1. アンケートを作成する

2. アンケートが非匿名で、トークンを使用していることを確認します。非匿名のアンケートを作成するには、

a - 一般設定アイコンをクリックします。

b - 参加者設定タブの匿名回答で"オフ"を選択します。

3. アンケートを有効にします。

アンケートを有効にするときは、"クローズド・アクセスモードに変更"ボタンをクリックしてトークンテーブルを作成します。

Switch to closed.png

4. 任意の方法でトークンテーブルに値を入力します(トークンページの指示に従います)。

5. アンケート結果をエクスポートして、トークン情報を入力してください。

エクスポートするには回答をクリックし...

Browse results.png

...エクスポートをクリックします。

Export2.png

アンケート結果に関連付けるには、トークンテーブルから1つまたは複数の要素を必ず選択してください。

Export tokens.png

6. アンケートをもう一度実施する際、アンケートとトークンテーブルはエクスポート・インポートを使用して簡単にコピーできます。この手順を繰り返すとともに、csvトークンインポートファイルを作成するときは同じ条件を使用してしてください。

問題と解決方法

Excel

インポートする前にExcelで回答を変更する

回答を複数同時に変更するには、ファイルをエクスポートしてExcelで開くことができます。データ(最初の行以外)を変更し、.txtファイルとして保存します。.csv形式で保存すると、ExcelはLimeSurveyにインポートされない形式のカンマ区切りとなります。.txtファイルとして保存すると、ExcelはLimeSurveyにインポートできるタブ区切りファイルとして保存します。

Excelで.csvを編集する

一般に、Excelは内部データ構造にいくつか変更を行い、インポートできなくなってしまうため、.csvファイルを編集するためにExcelを使用することは推奨しません。それでもExcelを使用したい場合は、システムコントロール(Windowsシステム)でExcel用のセパレータをカンマに設定する必要があります。

コントロールパネル|地域と言語のオプション|地域, カスタマイズ...|数値タブ|桁区切り記号| 「;」を「,」に置き換えます。

Excelで.csvファイルを編集する際の問題の回避策

Excelを使用して質問を編集すると、それらを再インポートできなくなる可能性があります。しかし、5つ以上のオプションやランキングオプションがあり、並べ替えなどのExcel機能を使用したい場合は、編集が必要です。

これは、基本的に1.82で動作すると思われる部分的な回避策です。データの部分にのみExcelを使用します。

  • 再利用したいものに類似した質問を.csvファイルとしてエクスポートします。
  • テキストエディタでCSVファイルを開きます。
  • 回答がある部分をExcelにコピーし、それを"区切り位置"機能または同等のもので解析します。
  • Excelの機能を使って、テキストを列に区切り、20、50、100個の回答を好きなように貼り付けます。
  • ファイルをExcelのCSV形式で保存します。これには引用符が含まれていない可能性があります。
  • このファイルをエディタで開き、"すべて選択"、"コピー"します。
  • テキストエディタで開いたファイルに戻ります。
  • 回答を貼り付けます。
  • 再利用するために覚えやすい名前を付けて保存します。
  • このファイルをインポートします。

Excel - 最大255列の制限

Excelの制限(2003以前のバージョン)により、LimeSurveyは同時に255列しかエクスポートできません。Microsoftは、VBマクロによる回避策を提案しています。

より新しい表計算ソフト(​​Excel 2007以降、OpenOffice)では255より多くのカラムを表示できますが、LimeSurveyで使用される内部モジュールは255カラムより多くエクスポートできません。

2つの回避策が可能ですが、次のいずれかのソリューションを使用してください。

  • CSVにエクスポートして表計算ソフトにインポートする
  • または、複数のエクスポート(一度に最大250の列を選択)を使用し、エクスポートされた結果をマージする

Excel/.csv - エクスポートの失敗

データをExcelまたは.csvファイルにエクスポートできない場合は、ブラウザのキャッシュとCookieをクリアしてください。

CSV

CSVの既定の列数は255

大規模アンケートをGUIでエクスポートする場合、既定ではエクスポートは最初の255カラムに制限されます。この問題を回避するには、エクスポートするすべてのデータセットにマークを付けます。

SPSSエクスポート

一般的な手順

LimeSurveyのアンケートデータをインポートするには、次の手順を実行してください。

  1. '回答をSPSSに出力'アイコンをクリックします。
  2. 選択ボックスから、エクスポートする回答とSPSSのバージョンを選択します。
  3. .sps(SPSS構文コマンドファイル)と.datファイル(データファイル)の両方をダウンロードしてください。
  4. SPSSで.spsファイルを開き、'別の種類のファイルを選択'を選択し、ダウンロードした.spsファイルを選択します。
  5. SPSの中でエディターが開き、そのファイル内のコマンドを編集できます。 '/FILE=...'で始まる行を探します。
  6. その行を編集し、.datファイルのパスに変更します。 例: *.datファイルはc:\tempにある場合、この行を/FILE='c:\temp\survey_(xxxx)_SPSS_data_file.dat'に設定してください。
  7. CTRL-Aを押して、エディター内のすべてのコマンドを選択します。
  8. SPSSメニューからRun/Allを選択します。
  9. すべてのデータとラベルをインポートするには時間がかかります。ステータスバーで進行状況を確認します。
  10. これで完了です。

SPSSで起こりうるエラーメッセージ

ERROR. command name:Get Data

ERROR. command name:Get Data. 2267 Unexpected Token missing.というエラーメッセージが表示された場合、構文ファイルの4行目を編集して、データファイルの絶対パスを次のように指定してください。

C:\spss\Data\limesurvey\SPSS\survey_35276_SPSS_data_file.dat

Error: "Text value unmappable in the current server locale"

このエラーは、SPSS 16でエクスポートされた構文ファイルを開こうとすると発生します。解決策は、SPSSに構文ファイルをUnicodeとして解釈させることです。

SPSSを開き、Edit > Options > Character encoding for data and syntaxを選択します。オプションを"unicode"に変更します。

これでLimeSurveyデータを問題なくSPSS 16にエクスポートできるようになります。

変数に使用するスケールを定義する

変数に使用される既定のスケールを上書きするには、scale_export という質問属性を適切な値に設定します。

VV Export/Import

VV - vv importで起こる問題

vvファイルの読み込みに問題がある場合は、タブ区切りのファイルを試してください。うまくいくはずです。

その他の問題と解決策

回答を別のアンケートにコピーする(トークンを使用)

  1. 新しいアンケートを作成し、ダミーの回答を追加し、回答ファイルをエクスポートしてExcelで開きます。これにより、新しいインポートファイルのフォーマットが作成されます。
  2. 古いアンケートの回答をトークンを含めてエクスポートし、Excelで開きます。
  3. このデータを使用して、標準的なトークンファイルインポート用のExcelワークシート(例: 名、姓、トークン、電子メールアドレス、電子メールステータス(OK)、言語(En))を作成します。 .csvとして保存し、LimeSurveyの新しいアンケートにトークンをインポートします。
  4. Excelで、新しいアンケートで必要となる古いアンケートの回答フィールド(トークンを含む)を新しいアンケートフォーマットの適切な列にコピーします。
  5. .txtファイルとして保存します。
  6. VVImportを使用して、新しいデータを新しいアンケートにインポートします。
  7. 考えられるインポートエラーとしては、日付形式が挙げられます。システム日付フィールドの中にはNULL値を許可しないものもあれば、するものもあります。 日付が問題ないようでもエラーが発生する場合は、Excelセル形式で"2009-12-01"を使用してください。