Actions

Ergebnisse exportieren

From LimeSurvey Manual

This page is a translated version of the page Exporting results and the translation is 50% complete.

Outdated translations are marked like this.
Other languages:
Deutsch • ‎English • ‎français • ‎日本語 • ‎Nederlands • ‎português do Brasil • ‎slovenščina

Contents




Mit einem Klick auf das File:Browse.png "Ergebnisse dieser Umfrage ansehen"-Symbol kommt man in das "Antworten anzeigen"-Menü. Mit einem weiteren Klick auf das Export.png "Ergebnisse dieser Umfrage für externe Anwendungen exportieren"-Symbol kann man die Umfrageergebnisse in eine Datei exportieren.

Browse results.png

Exportieren in Anwendung (Excel/.csv)

Es gibt mehrere Möglichkeiten die Daten zu exportieren, wir beginnen mit dem Export in CSV/Anwendung.

Export2.png

Zum exportieren von Dateien stehen folgende Optionen zur Verfügung:

  • Allgemein:

Wähle einen Bereich X bis Y welche Ergebnisse exportiert werden sollen

Wähle ob alle, nur vollständige oder nur unvollständige Aufzeichnungen exportiert werden

  • Fragen:

Wähle wie Überschriften aussehen sollen: Abgekürzte oder komplette Überschriften oder Fragencodes

Ersetze Leerzeichen in den Fragen durch Unterstriche

  • Antworten:

Sie können entweder die ganze Frage exportieren oder die Fragencodes Y und N in eine Variable konvertieren

  • Format:

Microsoft Word (Latin-Zeichensatz)

Microsoft Excel (alle Zeichensätze)

CSV File (alle Zeichensätze)

PDF

  • Spalteneinstellungen:

Wähle welche Antworten exportiert werden sollen. Alle antworten in dieser Liste werden durch ihren SGQA-Identifikator repräsentiert

Wähle welche Probandendaten exportiert werden sollen. Diese Funktion ist nur verfügbar wenn die Umfrage nicht anonym ist!

Export tokens.png

SPSS Export

Allgemein

SPSS Statistics ist ein Softwarepaket, das statistische Analyse verwendet wird. Sie können das offizielle SPSS-Paket verwenden oder PSPP als Ersatz für das proprietäre Programm SPSS verwenden.

Um die Antwortdaten in SPSS zu exportieren gehen Sie zum Bereich "Antworten und Statistiken" und wählen Sie im Menü 'Export' den Eintrag 'Antworten nach SPSS' exportieren.

Daten exportieren und filtern

Beim Exportieren in SPSS gibt es 2 Filteroptionen. Die können auswählen welche Daten ausgewählt werden sollen (alle/vollständige/unvollständige Aufzeichnungen) und für welche SPSS-Version die exportierten Dateien verwendet werden (vor Version 16/16 oder höher).

Der SPSS-Export beinhaltet zwei Dateien:

  1. eine Syntax-Datei (survey_xxxx_SPSS_syntax_file.sps)
  2. eine Datendatei (survey_xxxx_SPSS_data_file.dat)

Nach dem Download können Sie die Dateien mit einem einfachen Textprogramm ansehen und die exportierten Inhalte betrachten. Die Syntax-Datei beinhaltet die Kommandos die zum Importieren der Datei benötigt werden, diese sind wie eine eigene Programmiersprache für SPSS. Die Datendatei enthält alle exportierten Daten kommagetrennt. Wenn man die Daten einfach per CSV importiert gehen Daten (Information über Fragen,...) verloren, daher wird das nicht unterstützt.

Daten in SPSS importieren

Platzieren sie die beiden Dateien im selbem Ordner auf der Festplatte (Beispiel: c:\data\survey_xxxx_SPSS_syntax_file.sps und c:\data\survey_xxxx_SPSS_data_file.dat)

Jetzt gibt es zwei Optionen:

1. Wenn Sie Windows verwenden, navigieren Sie mit dem Explorer zum oben verwendeten Ordner. Wenn SPSS mit der Dateierweiterung .sps verknüpft ist, können Sie die Datei einfach durch Doppelklicken öffnen:

Spss explorer-screenshot.jpg

Jetzt können Sie Run->All im geöffneten Fenster wählen und nach einiger Zeit sehen Sie ihren Datensatz und können ihn als .sav-Datei speichern.

2. Es kann vorkommen, dass die obige, einfache Lösung nicht funktioniert. In diesem Fall fahren sie wie folgt fort:

  • Öffnen Sie SPSS
  • Wählen Sie Datei->Öffnen->Syntax
  • Wählen Sie die passende Datei: c:\data\survey_xxxx_SPSS_syntax_file.sps
  • Die Syntax Datei wird jetzt geöffnet.
  • Ändern sie die Zeile /FILE='survey_xxxx_SPSS_data_file.dat sodass sie den Pfad der Datendatei enthält: /FILE='c:\data\survey_xxxx_SPSS_data_file.dat
  • Jetzt markieren Sie den ganzen Kommandotext und wählen Auführen->Alles aus dem Menü, nach einiger Zeit (bitte seien Sie geduldig) bekommen sie den Datensatz mit allen Fragen, Labels, usw.

R Export

Fügen Sie ruhig mehr Information hinzu wenn Sie welche haben!

Die Freeware R ist eine Alternative für SPSS. Der R-Export ist dem SPSS-Export sehr ähnlich in LimeSurvey.

Anweisungen zum Importieren eines Datensatzes in R:

  1. Laden Sie die Syntax- und die Daten- Datei herunter.
  2. Speichern Sie beide Dateien im R Arbeitsverzeichnis (benutzen Siegetwd() undsetwd() im R-Kommandofenster um zu setzen und anzuzeigen).
  3. Geben Sie source("Surveydata_syntax.R", encoding = "UTF-8") im R-Kommandofenster ein

Instructions on how to import your dataset in R:

  1. Download both the syntax file and the data file.
  2. Store both files in R working directory (use getwd() and setwd() in a R command window to get and set).
  3. In your code enter source("Surveydata_syntax.R", encoding = "UTF-8") in R command window which will import the data in the correct format to a data frame called "data".


Responses with limited options will be factored with the levels matching the code of the question and the labels matching the options.

Questions with other as an option will have the question field with _Other appended as a new column for the other data.

NB: R-export is a plugin in Limesurvey. If you cannot find the R-export options (R (syntax file), R (data file)) under Export results to application, make sure the R-export plugin is enabled in the plugin menu.

STATA-xml Export

This option is available from version 2.05

STATA is a commercial data analysis and statistical software package.

This export routine was created to facilitate rapid analysis of data collected with LimeSurvey. It creates an XML-file in STATAs proprietary format, which can be imported independent of the platform STATA is run on. Using this format offeres several advantages over importing plain CSV files:

  • Data sets are fully labelled including variable labels (question, subquestion) and value labels (answers, if applicable).
  • Dates are already transformed to STATAs internal date format and thus can directly be used to calculate difference between days etc.
  • Variable names are, if necessary, converted to a STATA compatible format.
  • Data formats of variables (string, integer, float, etc.) are already set according to the underlying data. (No more numbers encoded as strings!).

Howto load the file in STATA: In STATA's menu, click on File, Import, xml-data. Choose browse to navigate to your exported file and click 'OK'. That should be it. If you prefer STATA's binary .dta files, you can just save your data again in this format.

Be aware:

  • Due to a limitation in STATA's data format, the length of string (text) variables have a maximum of 244 characters (Stata versions 8-12) and 2045 characters (Stata version 13 and above). Please indicate your Stata version in the settings of the export plugin.
  • STATA only supports attaching value labels to numerical values. So to achieve short answers (usually one or two digits) and have these properly labelled, one should use numerical answer-codes in LimeSurvey (1=Totally agree).cIf non-numerical answer codes are used (A=Totally agree), then the complete answer text will be used as answer (eg.: 'Totally agree').

VV-Umfrage exportieren(File:Exportvv.png) und importieren (File:Importvv.png)

Notice.png
Hint: This feature changed with version 2.05


Wenn sie einmal begonnen haben Antworten zu sammeln kann es vorkommen, dass Sie auf einfachem Weg größere Datenbestände ihrer Antworttabellen verändern wollen/müssen. Diese Änderungen sind meist mit einem Tabellenkalkulationsprogramm schneller und unkomplizierter zu bewerkstelligen.

Eine weitere Anwendungsmöglichkeit ist das manuelle Hinzufügen von Antworten sowie das Kopieren/Einfügen von Antworten aus anderen Tabellen (z.B. einer anderen Umfrage mit identischen Fragen/Antworten)

Bei VV-Export und Import ("VV" steht für "vertical verification") wird die Datei im .csv-Format exportiert und solange die generelle Struktur intakt bleibt, können sie alle Daten editieren und anschließend wieder importieren.

Bitte beachten Sie:

  • Wenn Sie Antworten mittels "VVImport" importieren möchten wählen Sie ob alle Daten überschrieben werden sollen oder ob die neuen Daten hinzugefügt werden sollen.
  • Wenn Sie Antworten aus einer anderen Umfrage mit gleichem Inhalt (z.B. gleiche Fragen/Antworten aus einer anderen Umfrage) importieren möchten, stellen Sie sicher, dass Sie die richtige VV-Datei verwenden und die ersten zwei Zeilen der CSV-Datei stimmen.
  • Wenn Sie eine Umfrage in ihre LimeSurvey-Installation importieren wird sich die SID der Umfrage (wenn möglich) nicht ändern. Die Gruppen- und Fragen-IDs könnte sich jedoch ändern. Es kann so passieren dass Sie die Kopfzeilen angepasst werden muss damit die Gruppen-/Fragen-IDs wieder stimmen. Siehe hierzu "Kopfzeilen einer vv Datei anpassen".

VVExport file version 2 (New in 2.05 )

This new feature allows different column names than the database. If your question code are unique, then the new version is selected. In the new version each column name uses the Qcode Variable Naming. For example this allows to update an existing survey in different installation more easily.

Eine Umfrage als VV-Datei exportieren

File:LimesurveyExportVVen.jpg

Wenn Sie die Antworten einer Umfrage mithilfe der VV-Export-Funktion exportieren möchten klicken sie auf die "VV-Umfrage-Datei exportieren" Schaltfläche. Sie können nun angeben die Antworten welcher Umfrage exportiert werden sollen. Des Weiteren besteht die Möglichkeit anzugeben ob alle, nur komplette oder nur unvollständige Antwortsätze exportiert werden sollen. Das letzte Eingabefeld bietet die Möglichkeit eine Dateiendung für die exportierte Datei festzulegen. Der Einfachheit halber sollte .csv verwendet werden.

Nach einem Klick auf "Ergebnisse exportieren" können sie die exportierte VV-Umfrage-Datei in Microsoft Excel oder jedem anderen kompatiblen Tabellenkalkulationsprogramm öffnen und bearbeiten. Die ersten beiden Zeilen des Tabellenblattes enthalten die Spaltenüberschriften/-bezeichnungen. Die erste Zeile enthält einen für den Benutzer lesbaren Spaltenkopf mit den Details zu den Fragen- und Antwort-Feldern. Die zweite Zeile enthält die entsprechenden programminternen Spaltennamen.

Wenn sie die modifizierte Datei zu einem späteren Zeitpunkt wieder in LimeSurvey importieren möchten, sollten sie auf keinen Fall die ersten beiden Zeilen des Tabellenblattes verändern!

You should not modify the first two rows of this spreadsheet if you want to be able to "import" the data back into LimeSurvey at a later point.

Exporting a VV survey file (New in 2.05 )

Notice.png
Hint: This features is available starting in version 2.05


VV2-export-en.png
  • Export survey : The survey ID to be exported (read-only)
  • Export : The completion state of the responses to be exported
  • File extension : The file extension. The file is a TSV (Tab-separated values) file. For easy opening in MS-Excel set the extension to .txt, with LibreOffice, OpenOffice or other spreadsheet program you can leave it to .csv.
  • VV export version : The 1.0 version uses database column headers, version 2.0 uses Qcode Variable Naming. Version 2.0 is selected by default if all of your question code are unique.

The first two rows of the spreadsheet are the column labels. The first row is a "human readable" column heading that details the name of the question. The second row is the real column name (Internal DB- or Qcode-name) for that response.

Ändern einer VV-Umfrage-Datei

Die exportierte VV-Umfrage-Datei kann mit Microsoft Excel oder jedem anderen kompatiblen Tabellenkalkulationsprogramm geöffnet und bearbeitet werden. Wenn nach einem Trennzeichen für Spalten gefragt wird muss "Tabulator" angeben werden. Wenn Umlaute (wie ä, ö oder ü) in der Umfrage vorkommen empfiehlt sich zudem einen Zeichensatz wie Unicode (UTF-8) zu verwenden damit jene Umlaute korrekt angezeigt werden.

Wie bereits erwähnt dürfen die ersten beiden Zeilen der VV-Datei nicht geändert werden da es sich um die Spaltenüberschriften handelt. Je nach Anwendungsfall kann unterschieden werden ob neue Antworten zu den vorhandenen Antworten einer Umfrage hinzugefügt werden oder alle Antworten einer Umfrage überschrieben werden sollen.

By default the first two rows of the .vv file are headers. If needed you can remove the first line to have a real TSV file. There are different use cases for importing a .vv file so we will differentiate between adding new responses to a survey and overwriting all responses of the survey.

Beispiel für den Aufbau einer VV-Datei:

VV version 1 TSV file

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	46492X40X1991
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1

VV version 2 TSV file

Response ID	Date submitted	Last page	Start language	Token	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage	token	QCODE
183	09.11.11 11:44	3	de	jsfhusdgqfygqsy	4
184	09.11.11 11:53	3	de	sdfhsifgsyergze	2
190	09.11.11 11:44	3	de	qsdqshkfhkdsjhj	1


Here SQGA identifier are not used - instead Qcode variable naming QCODE is used in the second line.

Reserved names

.VV file uses left and right brackets for reserved names, when importing this string is replaced by :

  • {question_not_shown} : NULL value in database. LimeSurvey use [empty string] for not answered question, and NULL value for question not shown (by Expression manager or max step in survey).
  • {quote} : " (a double quote)
  • {cr} : Carriage return
  • {newline} : A new line
  • {lbrace} : Left bracket (for example, if you want to have {cr} in response : use {lbrace}cr} )

VV Version 1 editing

Neue Antworten zu den existierenden Antworten hinzufügen

Überschreiben aller Antworten einer Umfrage

Wenn sie alle Antworten einer Umfrage überschreiben möchten können sie zu den vorhandenen/exportierten Antworten am Ende des Dokumentes neue Zeilen hinzufügen. Wie im Abschnitt "Neue Antworten zu den existierenden Antworten hinzufügen" erwähnt können die Antworten

manuell eingegeben werden oder kopiert und eingefügt werden, zum Beispiel aus einer anderen VV-Datei (aber nur die Antworten und nicht die Spaltenüberschriften kopieren).

Beispiel

1. Schritt: Datei öffnen

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
183	09.11.11 11:44	3	de	4
184	09.11.11 11:53	3	de	2
190	09.11.11 11:44	3	de	1


2. Schritt: Einfügen der neuen Antworten (am Ende des Dokuments)

Response ID	Date submitted	Last page	Start language	please vote from 1 to 6 (1 - super, 6 - worst)
id	submitdate	lastpage	startlanguage		46492X40X1991
1000	09.11.11 11:44	3	de	3
1001	09.11.11 11:53	3	de	3
1002	09.11.11 11:44	3	de	3

Die VV-Datei kann dann in die Umfrage importiert werden. Es sollte jedoch darauf geachtet werden die existierenden Antworten zu überschreiben. (siehe "Importieren eine VV-Umfrage-Datei")

Importieren eine VV-Umfrage-Datei

LimesurveyImportVVde.jpg

Solange die ersten beiden Zeilen des Tabellenblattes intakt sind, sollte der Importvorgang einer zuvor exportieren VV-Umfrage-Datei kein Problem darstellen. Es genügt ein Klick auf das File:Importvv.png "VV-Umfrage-Datei importieren"-Symbol und sie können die zu importierende Datei auswählen. Dazu können sie mit dem Setzen eines Häkchens bei "Datensatz IDs auslassen?" bestimmen, ob die Datensatz IDs beim Importvorgang kontrolliert werden sollen oder nicht. Für das Hinzufügen neuer Antworten (siehe Anwendungsfall "Neue Antworten zu den existierenden Antworten hinzufügen") sollte diese Option ausgewählt werden. Falls sie die vorhandenen Daten überschreiben möchten (Anwendungsfall "Überschreiben aller Antworten einer Umfrage") sollte der Haken bei dieser Option entfernt werden.

Falls der Haken entfernt wurde können sie festlegen, wie beim Importvorgang vorgegangen wird, wenn die ID eines bereits bestehenden Datensatzes mit einem zu importierenden Datensatz übereinstimmt:

  • Fehler anzeigen (und den neuen Datensatz überspringen)
  • Neue ID dem Datensatz zuweisen
  • Alten Datensatz ersetzen (diese Option sollte im Anwendungsfall "Überschreiben aller Antworten einer Umfrage") ausgewählt werden.

Then, from the browse screen, choose the "Import a VV Survey file" icon.

The "Import a VV Survey File" screen needs you to choose the "vvexport" file you are importing. If you choose to "Exclude Record IDs" the records will be imported and brand new Record ID's will be generated for them (use this option for the use case "Adding new responses to the existing responses of a survey"). If you un-check this box, then the original record id's will be imported (use this option for the use case "Overwriting all responses of the survey").

There are a range of options you can choose that tell LimeSurvey how to deal with double or multiple entries.

  • Report an error (and skip the new record).
  • Renumber the new record
  • Replace the existing record (uses this for the use case "Overwriting all responses of the survey")

Importing a VV survey file (New in 2.05 )

  • File : Select the file to be uploaded. The file must be a TSV file: A text file with each column separated by TAB.
  • Exclude record IDs? : If 'id' column exist in the file you can exclude this line or not. If this setting is checked then a new record is added for each line of the .vv file. If unchecked you can choose:
  • When an imported record matches an existing record ID:
    • skip : Report and skip the new record. After upload you will see if the record already existed - if it existed it's not imported.
    • renumber : Renumber the new record. A new record is added to the response table with answer of the VV file.
    • replace : Replace the existing record. The old record is deleted and completely replaced by the record from the VV file
    • replaceanswer : Replace response details from the file in the existing record. The old record is updated with the new response from the VV file. This allow to replace only one question in the response table.
  • Import as not finalized response? : If checked the submitdate is set to NULL, so the response is set to not completed.
  • Character set of the file : You can choose the character set of the file - the default and recommended value is UTF-8 but some spreadsheet program don't allow to choose a character set.
  • First line contains question codes : By default VV file first line contain human readable question, the real column names are in the second line. This allow to use the first line as the real column names.
  • Force import : If the question codes are not found in the database name or in Qcode Variable Naming then columns are assigned depending of order. This can be used to import VV file from different LimeSurvey instance but each survey must be exactly the same. We strongly recommend to use this only if you know what you are doing. It can be very dangerous and lead to results ending up in the wrong column.

Weitere Exportoptionen

Einzelne Antwort exportieren

Wenn sie eine einzige Antwort exportieren möchten können Sie dies auf folgende drei Arten machen:

1. Loggen Sie sich am LimeSurvey admin backend ein, wählen Sie ihre Umfrage, gehen Sie auf "Bearbeite Umfrageeinstellungen" -> "Benachrichtigungs und Datenmanagement" und stellen Sie sicher, dass sie grundlegende E-Mail Benachrichtigungen erhalten.

Jedes Mal wenn eine Umfrage abgeschlossen wurde, erhalten Sie einen Link: "Klicken sie auf den Link um die einzelne Antwort einzusehen"

Sie werden auf eine Seite weitergeleitet mit einem Button über den Daten "Exportiere diese Antwort"

2. Loggen Sie sich am LimeSurvey admin backend ein, wählen Sie ihre Umfrage und gehen Sie auf "Durchsuche Antworten für Umfrage". Klicken Sie auf "Antworten anzeigen" und die ID die Sie exportieren möchten in der linken Spalte. Dann klicken sie auf "Exportiere diese Umfrage" über den Daten.

3. Loggen Sie sich am LimeSurvey admin backend ein, wählen Sie ihre Umfrage "Exportiere Ergebnisse in Anwendung". Im letzten Feld über "Exportiere Daten" können Sie auswählen welchen Eintrag Sie exportieren möchten.

Vergleiche Antworten aus verschiedenen Umfragen (longitudinale Umfrage)

Wenn sie Umfrageergebnisse für bestimmte Personen über längere Zeit hinweg beobachten möchten kann Ihnen LimeSurvey helfen. Ein möglicher Anwendungsfall ist zum Beispiel die Überprüfung des Wissenssandes einer Gruppe vor und nach einem Seminar.

Die Schritte zur Umsetzung sind folgende:

1. Erstellen Sie die Umfrage

2. Stellen sie sicher, dass die Umfrage nicht anonym ist und Probanden verwendet. Um eine nicht anonyme Umfrage zu erstellen:

a. Klicken Sie auf den Umfrage bearbeiten-Button:

b. Unter dem Benachrichtigung & Datenmanagement Tab wählen Sie "Nein" für anonyme Antworten:

3. Aktivieren Sie die Umfrage.

Nachdem Sie die Umfrage aktiviert haben, klicken sie auf den "Wechseln in den beschränkten Zugriffsmodus" Button um die Probandentabelle zu erstellen:

Switch to closed.png

4. Erweitern Sie die Probandentabelle mit Methoden (folgen Sie den Anweisungen auf der Probanden Seite).

5. Exportieren Sie die Umfrageergebnisse und stellen Sie sicher, dass die Probandeninformationen beinhaltet sind.

Zum Exportieren klicken Sie durchsuche Ergebnisse...

Browse results.png

...und dann Exportieren:

Export2.png

Wählen Sie ein oder mehrere Elemente aus der Probandentabelle um diese mit Antworten zu verknüpfen:

Export tokens.png

6. Wenn Sie die Umfrage nochmals durchführen, was einfach durch das Kopieren der Umfrage und Probandentabelle mit Import/Export möglich ist, wiederholen Sie die Schritte einfach und stellen Sie sicher das die selbe Abfrage benutzt wird um die Probandenimportdatei (.csv) zu erstellen.

Probleme & Lösungen

Excel

Ändern der Antworten in Excel vor dem Import

Um mehrere Änderungen in Antworten zu machen, kann in Excel exportiert und geöffnet werden. Nehmen Sie die Änderungen vor und speichern Sie als .txt-Datei. Wenn Sie als. csv speichern, verwendet Excel Kommas welche nicht in LimeSurvey importiert werden. Beim Speichern als .txt-Datei wird der Inhalt tabulatorgetrennt gespeichert und in LimeSurvey importiert.

Bearbeiten von .csv in Excel

Grundsätzlich empfehlen wir Excel NICHT zum Bearbeiten exportierter Dateien zu verwenden, weil Excel Änderungen in der Struktur der Daten vornimmt was das Importieren unmöglich machen kann. Wenn Sie trotzdem Excel verwenden möchten müssen Sie das Komma als Trennzeichen für Excel in der Systemsteuerung festlegen:

Systemsteuerung|Zeit, Sprache und Region|Region und Sprache, Weiter Einstellungen...|Tab Zahlen|Symbol für Zifferngruppierung| ersetzen Sie . mit ,

Workaround zum Bearbeiten von .csv-Dateien mit Excel

Das Bearbeiten von Fragen mit Excel kann dazu führen das diese nicht wieder-importierbar sind. Bearbeiten ist aber der einzige Weg wenn man fünf oder mehr Kriterien oder Reihungskriterien hat, und Excels Features wie Sortieren u.s.w. benutzen möchte.

Folgend ist ein teilweiser Workaround welcher grundsätzlich in 1.82 funktioniert, benutzen Sie Excel nur im Datenbereich der Datei:

  • Exportieren Sie eine Frage ähnlich dem was Sie in der .csv-Datei wiederverwenden möchten
  • Öffnen Sie die .csv-Datei in einem einfachen Texteditor.
  • Kopieren Sie den Teil mit den Fragen in Excel hinein und parsen Sie den Text in Spalten oder ähnlich.
  • Nutzen Sie die Vorteile von Excel um viele Fragen auf einmal zu kopieren und automatisch in Spalten einzufügen
  • Speichern Sie die Datei als Excel CSV, welche keine Anführungszeichen enthält
  • Öffnen Sie die Datei im Editor, Wählen Sie alles aus und kopieren Sie
  • Gehen Sie wieder zu der Datei die Sie im Punkt 2) geöfnnet haben
  • Fügen Sie die Antworten ein
  • Speichern Sie die Datei unter anderem Namen, welchen Sie sich merken sollten um ihn später wieder verwenden zu können
  • Importieren Sie diese Datei

Excel - exportieren von maximal 255 Spalten möglich

Wegen Einschränkungen in Excel (bei Versionen bis ink. 2003), kann LimeSurvey maximal 255 Spalten auf einmal exportieren. Microsoft stellt ein Workaround als VB-makro zur Verfügung.

Obwohl neuere Tabellen (Excel >= 2007, OpenOffice) mehr als 255 Spalten anzeigen können, kann das interne Modul in LimeSurvey nicht mehr als 255 Spalten auf einmal exportieren.

Zwei Workarounds sind möglich, verwenden Sie eine der folgenden Lösungen:

  • Entweder Sie exportieren in CSV und importieren dann in die Tabelle
  • oder Sie exportieren mehrmals (maximal 250 Spalten pro Export) und fügen dann zusammen.

Excel/.csv -Export funktioniert nicht

Wenn das Exportieren in Excel oder ins CSV Format unmöglich ist dann leeren Sie ihren Browser-Cache und Cookies.

Tauschen von Zeilen/Spalten in Excel (Transponieren)

LimeSurvey exportiert die Ergebnisse in der Form von je einer Zeile je Datensatz, also in der ersten Zeile die Überschriften der Fragen bzw. deren Codes und in den Zeilen darunter die Ergebnisse.

Manchmal benötigt man jedoch eine Darstellung, in der die Überschriften alle in der ersten Spalte stehen und die Datensätze jeweils in einer eigenen Spalte daneben.

In Excel gibt es dazu die Funktion "Transponieren":

  • Alle Zeilen (Überschriften und Datensätze) markieren
  • Kopieren
  • Cursor in ein neues Tabellenblatt setzen
  • beim Menü Start/Einfügen im Pull-Down-Menu "Transponieren" auswählen (Symbol mit einem waagrechten und einem senkrechten Balken)

When exporting large surveys the GUI by default limits the export to the first 255 columns. To work around this, simply mark all data sets for export.

SPSS export

Allgemeine Schritte

Um LimeSurvey Antwortdaten zu exportieren befolgen Sie folgende Schritte:

  1. Klicken Sie auf das 'Exportieren in SPSS'-Symbol.
  2. Wählen Sie in den Auswahlboxen welche Antworten exportiert werden sollen und welche SPSS-Version Sie verwenden.
  3. Laden Sie beide Dateien herunter, die .sps (SPSS Syntax-Kommandodatei) und die .dat -Datei (Datendatei).
  4. Öffnen Sie die .sps-Datei in SPSS, dann wählen Sie 'Wähle anderen Datentyp' und wählen die heruntergeladene .sps-Datei.
  5. Ein Editor zum Ändern der Kommandos in der Datei öffnet sich direkt in SPSS. Suchen Sie die Zeile die mit '/FILE=...' startet.
  6. Ändern Sie die Zeile sodass der Pfad zu ihrer .dat-Datei führt. Beispiel: Ihre *.dat-Datei ist in c:\temp also ändern Sie die Zeile in:  /FILE='c:\temp\survey_(xxxx)_SPSS_data_file.dat'
  7. Wählen Sie alle Kommandos mit Strg + A.
  8. Wählen Sie im SPSS-Menü Ausführen->Alle.
  9. Seine Sie geduldig, es dauert etwas bis alles importiert wurde. In der Statusbar können Sie den Fortschritt beobachten.
  10. Fertig!

Mögliche Fehlermeldungen in SPSS

ERROR. command name:Get Data

Wenn Sie den Fehler ERROR. command name:Get Data. 2267 Unexpected Token missing. erhalten, ändern Sie die vierte Zeile der Syntax- Datei sodass der komplette Pfad angegeben ist, wie zum Beispiel:

C:\spss\Data\limesurvey\SPSS\survey_35276_SPSS_data_file.dat

Error: "Text value unmappable in the current server locale"

Dieser Fehler kann auftreten wenn Sie eine exportierte Syntax-Datei in SPSS 16 öffnen möchten. Die Lösung besteht darin das SPSS die Syntax-Datei als Unicode interpretiert.

Open SPSS. Go to Edit > Options > Character encoding for data and syntax. Change the option to "unicode".
Öffnen Sie SPSS. Wählen Sie Bearbeiten->Optionen->Zeichenkodierung für Daten und Syntax. Ändern Sie die Option in "unicode".

LimeSurvey-Daten können nun problemlos in SPSS 16 importiert werden.

Definieren Sie den Bereich einer Variablen mithilfe von Frageattributen

Es ist möglich den Standardbereich einer Variable zu verändern indem man Frageattribute #scale_export|scale_export mit dem entsprechendem Wert setzt.

VV Export/Import

VV - Probleme mit VV-Import

Wenn Sie Probleme mit dem Import von VV-Dateien haben verwenden Sie eine tabgetrennte Datei um das Problem zu beheben.

Andere Probleme und Lösungen

Kopieren von Antworten in eine andere Umfrage (Verwendung von Probanden)

  1. Erstellen Sie eine neue Umfrage, fügen Sie eine Dummy-Antwort hinzu, exportieren Sie die Antwortdatei, öffnen Sie sie in Excel. Dadurch wird das Format für die Eingabedatei erstellt.
  2. Exportieren Sie die Antworten aus der alten Umfrage, inklusive Probandeninformation und öffnen Sie in Excel.
  3. Verwenden Sie diese Daten um eine Arbeitsmappe für den standartmäßigen Probanden-Dateiimport zu erstellen(z.B. Vorname, Nachname, Proband, Email-Addresse, Email-Status (OK), Sprache(De). Speichern Sie als .csv und importieren Sie die Liste in die neue Umfrage in LimeSurvey.
  4. Kopieren Sie in Excel die alten Umfrageantworten die Sie in der neuen Umfrage haben möchten (inklusive Probanden) in die entsprechenden Zellen der neuen Umfrage.
  5. Speichern Sie als .txt-Datei.
  6. Benutzen Sie VVimport um die Daten in die neue Umfrage zu importieren.
  7. Mögliche Fehler beim Importieren sind zum Beispiel das Zeitformat - manche Systemzeit-Felder erlauben keine Null-Werte, andere wiederrum schon. Wenn das Datum richtig scheint, jedoch trotzdem Fehler auftreten, verwenden Sie das Excel Zellenformat "2009-12-01!