Actions

Translations

Difference between revisions of "Installation - LimeSurvey CE/9/de"

From LimeSurvey Manual

Line 1: Line 1:
 
System-Voraussetzungen:
 
System-Voraussetzungen:
 
* Minimum 200 MB freien Speicherplatz
 
* Minimum 200 MB freien Speicherplatz
* Min. MySQL 5.3.3 '''oder''' min. Microsoft SQL Server 2005 '''oder''' min. Postgres 8.1
+
* Min. MySQL 5.5.3 '''oder''' min. Microsoft SQL Server 2005 '''oder''' min. Postgres 8.1
 
* PHP 5.3.3 oder aktueller, (noch besser: PHP 5.5.x und aktueller) mit folgenden aktivierten Modulen:
 
* PHP 5.3.3 oder aktueller, (noch besser: PHP 5.5.x und aktueller) mit folgenden aktivierten Modulen:
 
** mbstring (Multibyte String Functionen) Erweiterungsbibliothek (siehe [[Installation FAQ#What is this mbstring (Multibyte String Functions) library?|Installations-FAQ (Englisch)]])
 
** mbstring (Multibyte String Functionen) Erweiterungsbibliothek (siehe [[Installation FAQ#What is this mbstring (Multibyte String Functions) library?|Installations-FAQ (Englisch)]])
 
** PDO Datenbanktreiber für MySQL (pdo_mysql oder pdo_mysqli) oder Postgres (pdo_pgsql) oder MSSQL ([http://php.net/manual/en/ref.pdo-sqlsrv.php pdo_sqlsrv] für Windows and [http://www.php.net/manual/en/ref.pdo-dblib.php pdo_dblib] für Linux)
 
** PDO Datenbanktreiber für MySQL (pdo_mysql oder pdo_mysqli) oder Postgres (pdo_pgsql) oder MSSQL ([http://php.net/manual/en/ref.pdo-sqlsrv.php pdo_sqlsrv] für Windows and [http://www.php.net/manual/en/ref.pdo-dblib.php pdo_dblib] für Linux)
 
** Im Allgemeinen gehen wir davon aus, dass alle PHP-Standard-Bibliotheken aktiviert sind (wie hash, session, etc.).
 
** Im Allgemeinen gehen wir davon aus, dass alle PHP-Standard-Bibliotheken aktiviert sind (wie hash, session, etc.).

Revision as of 17:58, 22 September 2016

Message definition (Installation - LimeSurvey CE)
The minimum set of requirements:
* Minimum 250 MB disk space.
* MySQL 5.5.3 or later '''OR''' Microsoft SQL Server 2005 or later '''OR''' Postgres 9 or later.
* Minimum PHP 7 or later; however, we recommend PHP 7.0.0+ with the following modules/libraries enabled:
** [[Installation FAQ#Requirements page#What is the mbstring (Multibyte String Functions) library|mbstring (Multibyte String Functions)]] extension library.
** PDO database driver for MySQL (pdo_mysql or pdo_mysqli) or Postgres (pdo_pgsql) or MSSQL ([https://php.net/manual/en/ref.pdo-sqlsrv.php pdo_sqlsrv] for Windows and [http://www.php.net/manual/en/ref.pdo-dblib.php pdo_dblib] for Linux).
** Also, we assume in general that all PHP default libraries are enabled 
*** hash
*** session
*** openssl or mcrypt
*** fileinfo
*** etc …
TranslationSystem-Voraussetzungen:
* Minimum 200 MB freien Speicherplatz
* Min. MySQL 5.5.3 '''oder''' min. Microsoft SQL Server 2005 '''oder''' min. Postgres 8.1
* PHP 5.3.3 oder aktueller, (noch besser: PHP 5.5.x und aktueller) mit folgenden aktivierten Modulen:
** mbstring (Multibyte String Functionen) Erweiterungsbibliothek (siehe [[Installation FAQ#What is this mbstring (Multibyte String Functions) library?|Installations-FAQ (Englisch)]])
** PDO Datenbanktreiber für MySQL (pdo_mysql oder pdo_mysqli) oder Postgres (pdo_pgsql) oder MSSQL ([http://php.net/manual/en/ref.pdo-sqlsrv.php pdo_sqlsrv] für Windows and [http://www.php.net/manual/en/ref.pdo-dblib.php pdo_dblib] für Linux)
** Im Allgemeinen gehen wir davon aus, dass alle PHP-Standard-Bibliotheken aktiviert sind (wie hash, session, etc.).

System-Voraussetzungen:

  • Minimum 200 MB freien Speicherplatz
  • Min. MySQL 5.5.3 oder min. Microsoft SQL Server 2005 oder min. Postgres 8.1
  • PHP 5.3.3 oder aktueller, (noch besser: PHP 5.5.x und aktueller) mit folgenden aktivierten Modulen:
    • mbstring (Multibyte String Functionen) Erweiterungsbibliothek (siehe Installations-FAQ (Englisch))
    • PDO Datenbanktreiber für MySQL (pdo_mysql oder pdo_mysqli) oder Postgres (pdo_pgsql) oder MSSQL (pdo_sqlsrv für Windows and pdo_dblib für Linux)
    • Im Allgemeinen gehen wir davon aus, dass alle PHP-Standard-Bibliotheken aktiviert sind (wie hash, session, etc.).